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KiCad is a open source (GPL) integrated package for schematic circuit capture and PCB
layout.

Before you start, you will need an installed copy of KiCad. This tutorial assumes that
KiCad is installed at C:\Kicad. You can download a copy from
http://iut-tice.ujf-grenoble.fr/cao/

Installation instructions are available on the web site under Infos:Install

1. Run “KiCad.exe”.

2. You are now in the main window:
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3. Create a new project: “File” -> “New”
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4. Click on the “New Folder” button, and name the new folder “tute1”.
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5. Open the new folder by double clicking on it.

6. Enter the name of the project in “File name”. In this tutorial we will call it “tute1”.
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7. Click “Open”. You should notice the project name should change to “tute1”.
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8. Click the Schematic editor button
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the Schematic editor.

9. In the error dialog that appears telling you that the file was not found, click “OK”.

Schematic Editor

10.You are now in the “EESchema” window. This window is used for entering
schematics.

11. You should first save the schematic project: “File” -> “Save Whole Schematic
Project”.
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12.Click the “page settings” button on the top toolbar.
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Page settings

13.Select the “Page Size” as “A4” and enter the “Title” as “Tute 1”. Click “OK”.

Insert Component symbols

14.In the EESchema window, click on the “Add components” button found in the right
toolbar or skip this step and attend step 15 key “A”.
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15.Click in the middle of the red box in the editing window to place your first
component, or hit the A-key. Note: Hit the ?-Key for a list of keyboard shortcuts.

16. A “Component selection” window will appear. You can enter part of a name, hit
Enter, and a search match list is presented. Or... execute next step.
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17.Click on “List All’. The “Select Lib” window will appear.
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18.Double click on the “device” library.

19. The “Select Component” window will appear.

- R
Select Component @

7SEGM
BATTERY

BI_LED

BNC

BREAKER
BRIDGE

C

CAPAPOL
CERAMIC_FILTER
CODING_SWITCH
COMMECTOR,

cp

cP1

CRYSTAL

CTRIM -

[t | »

[ Ok ][ Cancel ]

e

20. Scroll down and double click on “R”. This will close the “Select Component” dialog
and place component “R” onto your schema.

21.Place the component in the middle of the sheet by left clicking where you want it.



22.Click on the magnifier several time to zoom in on the component, or use the scroll
wheel of your mouse to pan & zoom.
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23.Hover the mouse over the component and press 'r' on the keyboard. Notice how the
component rotates.

24 Right click in the middle of the component and select “Edit Component” -> “Value”.
Or do not click: simply point and hit the V-key.
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25.The “Component value” window will appear.

F ™
Component value m

Yalue

1K

Ik l [ Zancel




26.Replace the current “Value” “R” with “1k”.
27.Click “OK”.

28.The value inside the resistor should now be “1k” .

R &
29.To place another resistor, click on the place you want the resistor to appear, hit Ins,
this will repeat the last component, or hit C while the mouse hovers the last resistor.

30. The “Component selection:” window will appear.

31.The resistor you previously chose is now in your history list appearing as “R”.
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32.Click on “R”.
33.Place the resistor on the page

34.Repeat and place a third resistor on the page.



35.Right click on the second resistor and click on “Delete Component”. This will
remove the component from the schematic.
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36.Right click on the third resistor. Select “Move Component”.

37.Reposition the component and left click to drop.

38.Repeat steps 24 to 27 on the third resistor and replace “R” with “100”
39.Repeat steps 14 to 20, however this time select the “microcontrollers” library

instead of the “device” library and the “PIC12C508A” component instead of the “R”
component.
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40.Hover the mouse over the microcontroller component. Press'y' and 'x' on the
keyboard. Notice how the component is mirrored on its x and y axes. Press'y' and
'X' again to return it to its original orientation.

41.Repeat steps 14 to 20, however this time choose the “device” library and the “LED”
component.

42.0rganise the components on the page in the following way:
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43.Sometimes a component that you want to place on your schematic isn’t in your
component libraries. We will now add a new component to the library.

Component Library Editor
44.Click on the “go to library editor” button on the top toolbar.
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45.This will open the “Component Library Editor” window.
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46.Click on the “Select working library” button.
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47.In the “Select Library” window click on “conn” and click “OK”.
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48.Click on the “New component” button.
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49.The Component Properties window will appear.
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50.Name the new component “MYCONNS3”. Enter the “Default reference designator” as
“J”, and the “Number of parts per package” as “1”.

51.Click “OK”
52.1f the warning “has a convert drawing” appears click “yes”.

53.1n the middle of the screen the name of the component will appear. Click on the
magnifier a few times to zoom in on it.

54.Click on the “Add Pins” button on the right toolbar.

=] || &

(=1
=)
=

- | Ad

» 1@

55. Left click on the part editor screen just below the “MYCONNS3” label.



56.In the “Pin Properties” window that appears, enter pin name as “VCC”, enter the pin
number as “1”, and select “Electrical type” as “Power output” then click “OK”.
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57.Place the pin by clicking at the location you would like it to appear, right below the
“MYCONNS3” label.

58.Repeat steps 55 to 57. This time, “Pin name” should be “INPUT”, 'Pin number”
should be “2”, and “Electrical Type” should be “Power input”.

59.Repeat steps 55 to 57. This time “Pin name” should be “GND”, “Pin number” should
be “3”, and “Electrical Type” should be “Power output”.

60.Arrange the pins like this:
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61.Click on the “Add rectangle” button.
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62.We want to draw a rectangle around the pins, as is seen below. To do this, click
and release the left mouse button where you want the top left corner of the
rectangle to be. Then move your mouse to where you want the bottom right
rectangle corner to be and again click the left button.
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63.Click on “Update current component in current library” on the top toolbar.
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64.Click on “Save current loaded library on disk (file update)” on the top tool bar.
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65.Click “Yes” in any confirmation messages that might appear.



66. You can now close the “Component Library Editor” window. You will be returned to
the EESchema window.

67.Repeat steps 14 to 20, however this time choose library “conn” and component
‘MYCONNS3”.

68. Your newly created part will appear. Choose a location near the second resistor to
place this component. Press the 'y' key to mirror it on the y axis.
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69. The component identifier “J?” will appear under the “MYCONNS3” label. Right click
on “J?” and click on “move field”. It might be helpful to zoom in a bit before doing

this. Reposition “J?” to under the pins.
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70.Click on the “Add powers” button on the right toolbar, or skip this and use a shortcut
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71.Click above the pin of the 1k resistor, or hit the P-key.

72.1n the “Component selection” window, click the List All button.
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73.Scroll down and select “VCC” in the “Select Component” window. Click OK.
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74.Click above the pin of the 1k resistor to place the part.
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75.Click above the VDD pin near the microcontroller.

76.1n the “Component Selection history” select “VCC” and click again next to the VDD
pin.

77.Repeat again and place the VCC pin above the VCC pin of “MYCONN3”.
78.Repeat steps 70 to 72 but select GND this time.
79.Place a GND pin under the GND pin of “MYCONN3".

80.Place another GND symbol a little to the right and below the VSS pin of the
microcontroller. Your schematic should look something like this:
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(Schematic continued)

Connecting

81.Click on the “Place a wire” button on the right toolbar. **Be careful not to pick “Place
a bus” which appears directly beneath this button but has thicker lines**. Or you can
skip this step and use a shortcut key.
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82.Left click on the little circle on the end of pin 7 of the microcontroller and then on the
little circle on pin two of the LED. Alternatively, you can use the W key instead of a
mouse click. Note: sometimes, a double-click is necessary to end a wire. In such a
case the W cannot terminate a wire. When click/W while not at a small circle, then a

bend is inserted.
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83.Repeat this process to wire up the other components as below. To terminate a wire
that isn’t connected to anything, double-click the left mouse button. When wiring up

the VCC and GND symbols, the wire should touch the bottom of the VCC symbol
and in the middle top of the GND symbol.
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84.Label the nets by clicking on the “Place net name” button on the right toolbar
(optional: not named nets get an alphanumeric name — you may proceed to step 92.
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85.Click in the middle of the wire between the microcontroller and the LED.



86. Enter the name “uCtoLED”.

87.Click near the circle (little to the right) of pin 7 to place the net name.
88.Name the wire between the resistor and the LED to “LEDtoR”.
89.Name the wire between “MYCONNS3” to the resistor as “INPUTtoR”.
90.Name the line on the right of the 100 ohm resistor as “INPUT".

91.Name the line from pin 6 as “INPUT”. This creates an invisible connection between
the two pins labelled “INPUT”. This is a useful technique when connecting wires in a
complex design where drawing the lines would make the drawing very messy.

92.You do not have to label the VCC and GND lines, the labels are implied from the
power objects they are connected to.
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93. The program checks for wiring errors. Any wires that are not connected may
generate a warning. To avoid these warnings you can instruct the program that the
unconnected wires are deliberate.



94. Click on the “Place no connect” flag button on the right toolbar.
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95.Click on the little circle at the end of lines 2, 3, 4 and 5. X’s will appear to signify
that the lack of a connection is intentional.
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96.To add comments on the schematic use the “Place graphic text (comment)” on the

right toolbar.
i
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Have unique Component Identifiers assigned

97.The components now need to be given unique identifiers. To do this click on the
“‘Annotate schematic” button.
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98.1n the “Annotate Schematic” window, select “Use the current page only” and click
the “Annotation” button.
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99. Click “OK” in the confirmation message and then click “Close” in the “Annotate
Schematic” window.

100. Notice how all the “?” on the components have been replaced with a
number. Each identifier is unique. In our example “R1”, “R2”, “U1”, “D1” and “J1”.



101. Click on the “Schematic Electric Rules Check” button. Push the “Test ERC”
button in the window that appears.
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102. This will generate a report to inform you of any errors or warnings such as
wires being disconnected. You should have 0 Errors and 0 Warnings. A small green
arrow will appear in the location of the error if you have made a mistake. Check
“Write erc report” and press the “Test ERC” button again to receive more
information about the errors.

Preparations for Layout

103. Click on “Netlist generation” on the top toolbar.
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104. Click “Netlist” then on “save” to the default file name.
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105. Click on “Run Cvpcb” on the top toolbar.
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106. Click OK if an error appears about not being able to open a component
library.

107. Cvpcb permits you to link footprints to components. In the pane on the left,
select “D1”. In the pane on the right, scroll down to “LEDV” and double click on it.
'f-E CvPCE (2010-05-05 BZR 2356)-stable CAKiCad\tutel\tutel.net l =RREN X
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108. For “J1” select the “3PIN_6mm?” footprint.
109. For “R1” and “R2” select the “R1” footprint from the light green screen.
110. Select “DIP-8__ 300" for “U1”.
111. Click on “File”->"Save As”. The default name “tute1.net” is fine, so click save.
112. Back in the schema editor, save the project by clicking on “File” -> “Save
Whole Schematic Project”.
113. Switch to KiCad main window.
114. Select “Browse” -> “View File”.
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115. If an error message appears, choose your text browser. Most Windows

computers have one at “c:\windows\system32\notepad.exe”.

116. Select the “tute1.net” file. This will open your netlist file. It describes which
components and which pins are connected to which pins.

117. Close your text editor and return to the “EESchema” window.



118. To create a bill of materials, click on the “Bill of materials” button on the top
toolbar.
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119. Click “OK” and then “Save”.
120. To view the file repeat steps 113-115 and select “tute1.Ist”.

121. Close the text editor.

Layout Editor

122. Now click on the “Run Pcbnew” button on the top toolbar.
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123. The “Pcbnew” window will open.
124. Click “OK” on the error message about the file not existing.
125. Click on “File” -> “Save”.

126. Click the “Page settings” button on the top toolbar.
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127. Select “paper size” as “A4” and enter “title” as “Tute 17 .

128. It's a good idea to set your clearance and minimum track width settings to
those required by your PCB manufacturer. As an example of this, we’ll set our
clearance to 0.015” and our minimum track width to 0.01”.

129. Click on the “Design Rules” -> “Design Rules” menu.
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130. If it's not already showing, click on the “Net Classes Editor” tab.



131. Change the “Clearance” field at the top of the window to “0.015” and the
“Track Width” field to “0.01”
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132. Click on the “Global Design Rules” tab and set “Min track width” to 0.01”.
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133. Click the OK button to commit your changes and close the Design Rules

Editor window.

134. Click on the “Read Netlist” button on the top toolbar.
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135. Click the “Browse Netlist Files” button, select “tute1.net” in the file selection
dialog, and click on “Read Current Netlist”. Then click the “Close” button.
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136. The components will be placed in the top left hand corner just above the

page. Scroll up if you can’t see them.

Placing Footprints

137. Right click on a component, click on that component’s name at the top of the
menu, and then click “Move”. Move the component to the middle of the board.
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138. Repeat previous step until all the components are in the middle of the page.

139. Make sure that the “Hide board ratsnest” button is selected so you can see
the ratsnest of wires linking the components (Note: the tooltip is backwards;



pressing this button displays the ratsnest).

Hide board ratsnest
i

&
&
&
it
140. Move the components around until you minimise the number of wire
crossovers.
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141. If the ratsnest disappears or the screen gets messy right click and click
“‘Redraw view”.

Add tracks

142. Now we will connect up all of the wires except the ground wire on the “front”
layer.



143. Select “Front” in the drag down menu on the top toolbar.
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144, Click on the “Add Tracks and vias” button on the right toolbar.

Add tracks and vias

145. Click in the middle of pin 1 of “J1” and run a track to the pad “R2”. Double-
click to set the track’s end point.

146. Repeat this process till all wires except pin 3 of J1 is connected.

MYCONN3




147. Select “Back” in the drag down menu on the top toolbar.
148. Click on “Add tracks and vias” button.

149. Draw a track between pin 3 of J1 and pin 8 of U1.

150. Click on “Net highlight” button on the right toolbar.
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151. Click on pin 3 of J1. It should turn yellow.

Generate Copper Planes
152. Click on “Add Zones” button on the right toolbar.
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153. We’re going to trace a rectangle around the board, so click where you want
one of the corners to be. In the dialog that appears, set “Pad in Zone:” to “Thermal
relief” and “Zone edges orient:” to “H,V”, and then click “OK”.

154. Trace around the outline of the board by clicking at each corner in rotation.
Double-click to finish your rectangle.

155. Right click inside the area you have just traced.
156. Click on “Fill or Refill All Zones”. The board should fill in with green.

157. Your board should look something like this:
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158. Now select “PCB Edges” from the dropdown menu in the top toolbar.

159. Select the “Add graphic line or polygon” button on the right toolbar.

Add graphic line or pelygon |

160. Trace around the edge of the board, clicking at each corner, and remember
to leave a small gap between the edge of the green and the edge of the PCB.

161. Run a design rules check by clicking on “Perform Design Rules Check”.
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162. Click on “Start DRC”. There should be no errors.
163. Click on “List Unconnected”. There should be no unconnected.

164. Click “OK” to close the DRC Control dialog.



165. Save your file by clicking on “File” -> “Save”.

166. To admire your board in 3D, click on “3D Display” -> “3D Display”.
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167. You can drag your mouse around to rotate the PCB.

168. Your board is complete. To send it off to a manufacturer you will need to
generate a GERBER file.

Postprocessing
169. Click on “File” -> “Plot”.

170. Select “Gerber” as the “Plot Format” and click on the Plot button. Click Quit to
close the Plot dialog.

171. To view GERBER files go to the main KiCad window.
172. Click on the “GerbView” button.
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173. On the drag down menu select “Layer 1.

174. Click on “File” -> “Load Gerber file”.
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175. Select the file named “tute1-Front.gtl” and then on “open”.

176. Repeat steps 173 through 175, this time selecting “Layer 2” and then loading
“tute1-Back.gbl”.

177. Repeat steps 173 through 175, this time selecting “Layer 3” and then loading
“tute1-SilkS_Front.gbo”.

178. Repeat steps 173 through 175, this time selecting “Layer 4” and then loading
“tute1-SilkS_Back.gbo”.

This way you can examine the layers that will be sent to production.

Footprint Editor

There is a extensive footprint library with KiCad, however on occasion you might find
that the footprint that you need is not in a KiCad library. Here are the steps for creating
a new PCB footprint in KiCad:

179. Go back to PCBnew window.



180. Click on “Open Module Editor” button on the top toolbar.
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181. This will open the “Module Editor”.

182. Click on “select working library” on the top toolbar.
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183. For this exercise select the “connect” library.

184. Click the “New Module” button on the top toolbar.
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185. Enter “MYCONNS3” as the “module reference”.

186. In the middle of the screen a “MYCONNS3” label will appear.

187. Under the label will be “VAL**”.

188. Right click on “MYCONN3” and move above “VAL**”.

189. Right click on “VAL**”, select “Edit Text Mod” and rename it to “SMD”.
190. Check the “Display” value to “Invisible”.

191. Select the “Add Pads” on the right toolbar.

O

192. Click on the screen to place the pad.



193. Right click on the new pad and click “Edit Pad”.
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194. Set the “Pad Num” to “1”, “Pad Shape” to “Rect’, “Pad Type” to “SMD”,

“Shape Size X” to “0.4”, and “Shape Size Y” to “0.8”. Click “OK”.

195. Click on “Add Pads” again and place two more pads.

MYCONN3

196. Move the “MYCONNS3” and “SMD” labels out of the way so it looks like
above.

197. Click on “Add graphic line or polygon” button in the right toolbar.
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Add graphic line or polygon

198. Draw an outline of the connector around the component.
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199. Click on “Save Module in working directory” on the top toolbar, using the
default name, MYCONNS.

A=V R L N

iri|Save Module in working Iibraryl

200. You can now return to PCB new and click on “Add modules” button on the
right toolbar.
{F
201. Click in the screen, and the module name window will pop-up.

202. Select the module “MYCONNS3” and place it on your PCB design.

This has been a quick tutorial on most of the features in KiCad. For more detailed
instructions there is a detailed help file which can be accessed through all KiCad modules.
Click on Help -> Contents.
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