Graphical Internet

deluge - A GTK+ BitTorrent client with support for DHT, UPnP, and PEX

Deluge is a new BitTorrent client, created using Python and GTK+. It is
intended to bring a native, full-featured client to Linux GTK+ desktop
environments such as GNOME and XFCE. It supports features such as DHT
(Distributed Hash Tables), PEX (ĀµTorrent-compatible Peer Exchange), and UPnP
(Universal Plug-n-Play) that allow one to more easily share BitTorrent data
even from behind a router with virtually zero configuration of port-forwarding.
License:GPL Group:Graphical Internet
URL:http://deluge-torrent.org/ Source: deluge

Packages

Name Version Release Type Size Built
deluge 0.5.3 1.fc6 x86_64 4.53 MiB Wed Jul 25 23:17:57 2007

Changelog

* Wed Jul 25 18:00:00 2007 Peter Gordon <peter{%}thecodergeek{*}com> - 0.5.3-1
- Update to new upstream release candidate (0.5.3)
- Drop %ifarch invocations for 64-bit builds. The internal setup script now
  properly determines this and adds the AMD64 compiler definition if necessary.
* Tue Jul 24 18:00:00 2007 Peter Gordon <peter{%}thecodergeek{*}com> - 0.5.2-1
- Update to new upstream release (0.5.2)
- Update Summary and %description to reflect new ĀµTorrent-compatible Peer
  Exchange ("PEX") functionality.
- Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
* Wed Mar 7 17:00:00 2007 Peter Gordon <peter{%}thecodergeek{*}com> - 0.4.99.1-1
- Update to new upstream release (0.5 RC1).
- Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
  it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
  - 64bit-python_long patch
  (This should fix the bug where, even though torrents are active, they are not
  shown in the GtkTreeView listing.)
- Use rewritten setup.py instead of patching it so much, since it's easier to
  maintain across version upgrades and whatnot:
  + fixed-setup.py
- Remove the setup.py patch (no longer needed, since I'm packaging my own):
  - setup.py-build-against-system-libtorrent.patch

Listing created by RepoView-0.5.2-1.fc6 (modified)